summaryrefslogtreecommitdiff
path: root/lib/ExecutionEngine/Interpreter/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2016-11-17 04:36:50 +0000
committerChris Bieneman <beanz@apple.com>2016-11-17 04:36:50 +0000
commit92cb3eecbd9ba49ef04ed1b0cd70c549cace5d4c (patch)
treee84924a501e8f6808ecd65a41d101c74b7cce99e /lib/ExecutionEngine/Interpreter/CMakeLists.txt
parent44a5962ac51c6b6892fcbbfda15f8e695f418a7a (diff)
[CMake] NFC. Updating CMake dependency specifications
This patch updates a bunch of places where add_dependencies was being explicitly called to add dependencies on intrinsics_gen to instead use the DEPENDS named parameter. This cleanup is needed for a patch I'm working on to add a dependency debugging mode to the build system. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@287206 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/ExecutionEngine/Interpreter/CMakeLists.txt')
-rw-r--r--lib/ExecutionEngine/Interpreter/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/lib/ExecutionEngine/Interpreter/CMakeLists.txt b/lib/ExecutionEngine/Interpreter/CMakeLists.txt
index 4dbc2df4c74..7456b3dbe90 100644
--- a/lib/ExecutionEngine/Interpreter/CMakeLists.txt
+++ b/lib/ExecutionEngine/Interpreter/CMakeLists.txt
@@ -10,10 +10,11 @@ add_llvm_library(LLVMInterpreter
Execution.cpp
ExternalFunctions.cpp
Interpreter.cpp
+
+ DEPENDS
+ intrinsics_gen
)
if( LLVM_ENABLE_FFI )
target_link_libraries( LLVMInterpreter PRIVATE ${FFI_LIBRARY_PATH} )
endif()
-
-add_dependencies(LLVMInterpreter intrinsics_gen)