summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Beckmann <ecbeckmann@google.com>2017-07-26 01:21:55 +0000
committerEric Beckmann <ecbeckmann@google.com>2017-07-26 01:21:55 +0000
commitf74bed27b433390460f80b2b6d1235cbadc5f482 (patch)
treecb5e8a7244d7936dbdfbd827f9af5c8fbb10c408 /lib/CMakeLists.txt
parent49fc1e6fbc4dbcde96f77f13f9d47e717f83872b (diff)
Move manifest utils into separate lib, to reduce libxml2 deps.
Summary: Previously were in support. Since many many things depend on support, were all forced to also depend on libxml2, which we only want in a few cases. This puts all the libxml2 deps in a separate lib to be used only in a few places. Reviewers: ruiu, thakis, rnk Subscribers: mgorny, hiraditya, llvm-commits Differential Revision: https://reviews.llvm.org/D35819 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@309070 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 946067e6358..71b0a0aa0d3 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -25,3 +25,4 @@ add_subdirectory(Passes)
add_subdirectory(ToolDrivers)
add_subdirectory(XRay)
add_subdirectory(Testing)
+add_subdirectory(WindowsManifest)