summaryrefslogtreecommitdiff
path: root/examples/Kaleidoscope/CMakeLists.txt
diff options
context:
space:
mode:
authorDuncan P. N. Exon Smith <dexonsmith@apple.com>2015-01-06 23:39:37 +0000
committerDuncan P. N. Exon Smith <dexonsmith@apple.com>2015-01-06 23:39:37 +0000
commitc1824769744d2052963962b2b8cbf0180bd4868b (patch)
treefd77cda3f8e4be7818b760cccdbf2e1c884f5a9e /examples/Kaleidoscope/CMakeLists.txt
parent2848d9262016a14169a429c2fef9ae48570499b3 (diff)
cmake: Add Kaleidoscope target
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@225318 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'examples/Kaleidoscope/CMakeLists.txt')
-rw-r--r--examples/Kaleidoscope/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/examples/Kaleidoscope/CMakeLists.txt b/examples/Kaleidoscope/CMakeLists.txt
index 25e5745626e..53c724f1a2d 100644
--- a/examples/Kaleidoscope/CMakeLists.txt
+++ b/examples/Kaleidoscope/CMakeLists.txt
@@ -1,3 +1,10 @@
+add_custom_target(Kaleidoscope)
+
+macro(add_kaleidoscope_chapter name)
+ add_dependencies(Kaleidoscope ${name})
+ add_llvm_example(${name} ${ARGN})
+endmacro(add_kaleidoscope_chapter name)
+
add_subdirectory(Chapter2)
add_subdirectory(Chapter3)
add_subdirectory(Chapter4)