summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMehdi Amini <mehdi.amini@apple.com>2016-11-09 00:23:20 +0000
committerMehdi Amini <mehdi.amini@apple.com>2016-11-09 00:23:20 +0000
commitecca5dd36c95d5c0a129aeef14af08796c38eb0d (patch)
tree475f80ccf44c95ca13cacf405d05a52fb0d9a21f /CMakeLists.txt
parenta20694002c0fc014b0e1770be1b1921d1e59a6a3 (diff)
[cmake] Fix handling compiler-rt in LLVM_ENABLE_PROJECTS by turning any "-" into "_"
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@286317 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9fcb30a5b20..f67fd23860e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -109,6 +109,7 @@ foreach(proj ${LLVM_ENABLE_PROJECTS})
message(FATAL_ERROR "LLVM_ENABLE_PROJECTS requests ${proj} but directory not found: ${PROJ_DIR}")
endif()
string(TOUPPER "${proj}" upper_proj)
+ STRING(REGEX REPLACE "-" "_" upper_proj ${upper_proj})
set(LLVM_EXTERNAL_${upper_proj}_SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/../${proj}")
# There is a widely spread opinion that clang-tools-extra should be merged
# into clang. The following simulates it by always enabling clang-tools-extra