summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVassil Vassilev <v.g.vassilev@gmail.com>2017-03-23 14:54:34 +0000
committerVassil Vassilev <v.g.vassilev@gmail.com>2017-03-23 14:54:34 +0000
commitbe249eda2a402bf6a04eab3ef8a21d3fd2d386b2 (patch)
tree06a4bfc73f2cd9c52063a102ab33a20ee3d3f849 /CMakeLists.txt
parentb9056a6799783cb8ebe29311d4780c5e06c1366e (diff)
Do not polute the source directory.
When a python script is run, by default it creates the bytecode file if the directory is writable, and this ‘pollutes’ source folders. From python's help: -B Don’t write .py[co] files on import. See also PYTHONDONTWRITEBYTECODE. Patch by Pere Mato (D30604)! git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@298603 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3c2c7091539..47bd35c0988 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -618,7 +618,7 @@ endif (LLVM_USE_OPROFILE)
message(STATUS "Constructing LLVMBuild project information")
execute_process(
- COMMAND ${PYTHON_EXECUTABLE} ${LLVMBUILDTOOL}
+ COMMAND ${PYTHON_EXECUTABLE} -B ${LLVMBUILDTOOL}
--native-target "${LLVM_NATIVE_ARCH}"
--enable-targets "${LLVM_TARGETS_TO_BUILD}"
--enable-optional-components "${LLVMOPTIONALCOMPONENTS}"