summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVadim Chugunov <vadimcn@gmail.com>2017-01-28 07:39:52 +0000
committerVadim Chugunov <vadimcn@gmail.com>2017-01-28 07:39:52 +0000
commita8dd82bf5e3c3fa32f60e2de85d3acc5f1536f8d (patch)
tree698eec42fc857e147a1fe9d793b8863671c3a9a9 /CMakeLists.txt
parent647e08195b3cd45cee0059fe8bb0a07b504006ec (diff)
This addresses LLDB bug 31699, which was caused by LLVM using static linking on Windows.
In order to make sure that LLVM continues to work on machines that do not have the Universal CRT yet, we'll need to ship a copy of UCRT in the Windows installation package. Fortunately, CMake 3.6+ already supports app-local deployment of UCRT dlls, we just need to turn this on. Differential Revision: https://reviews.llvm.org/D29146 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@293373 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5cb24ea7d78..c2c9fe0a68b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -978,3 +978,8 @@ if(LLVM_DISTRIBUTION_COMPONENTS)
endif()
endforeach()
endif()
+
+# This allows us to deploy the Universal CRT DLLs by passing -DCMAKE_INSTALL_UCRT_LIBRARIES=ON to CMake
+if (MSVC)
+ include(InstallRequiredSystemLibraries)
+endif()