summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBob Wilson <bob.wilson@apple.com>2017-03-07 00:51:07 +0000
committerBob Wilson <bob.wilson@apple.com>2017-03-07 00:51:07 +0000
commit8441750c177fabb7a26c514a982be1a53e1573dd (patch)
tree735dbcb083fcf8435cefb17badbf932df9ea15f8 /CMakeLists.txt
parent48a77b752379470c85a30f63f45c04bd0d89f3a7 (diff)
remove Cmake option for LLVM_DISABLE_ABI_BREAKING_CHECKS_ENFORCING
This is a follow-up to my change in r295090, which added support for disabling these checks selectively based on setting the preprocessor macro without relying on the Cmake setting. Swift has moved over to use that approach, so we can clean up here and remove the Cmake setting. https://reviews.llvm.org/D30578 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@297109 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 68caedbf9de..3937aa01352 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -396,9 +396,6 @@ option(LLVM_ENABLE_EXPENSIVE_CHECKS "Enable expensive checks" OFF)
set(LLVM_ABI_BREAKING_CHECKS "WITH_ASSERTS" CACHE STRING
"Enable abi-breaking checks. Can be WITH_ASSERTS, FORCE_ON or FORCE_OFF.")
-option(LLVM_DISABLE_ABI_BREAKING_CHECKS_ENFORCING
- "Disable abi-breaking checks mismatch detection at link-tim." OFF)
-
option(LLVM_FORCE_USE_OLD_HOST_TOOLCHAIN
"Set to ON to force using an old, unsupported host toolchain." OFF)