summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRafael Espindola <rafael.espindola@gmail.com>2017-06-30 18:48:33 +0000
committerRafael Espindola <rafael.espindola@gmail.com>2017-06-30 18:48:33 +0000
commit78fbc18aed8024139cb87c5db69ab5b43dc615d6 (patch)
tree31a028c3d994964e4b08d85cd4821fa1862c5f5b /CMakeLists.txt
parent61b3e82aaa7c64a03d458cd40a17becb71ff38bb (diff)
Completely disable git/svn version checking if not needed.
Working with git on a branch I find it really annoying that committing a change causes ninja to think that stuff needs to be rebuilt. With this change at least nothing in llvm needs to be rebuild when something is committed. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@306858 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9cdc688d42b..fc05f30e4cd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -206,7 +206,7 @@ endif()
include(VersionFromVCS)
option(LLVM_APPEND_VC_REV
- "Append the version control system revision id to LLVM version" OFF)
+ "Embed the version control system revision id in LLVM" ON)
if( LLVM_APPEND_VC_REV )
add_version_info_from_vcs(PACKAGE_VERSION)