summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Bradbury <asb@lowrisc.org>2017-08-13 18:49:33 +0000
committerAlex Bradbury <asb@lowrisc.org>2017-08-13 18:49:33 +0000
commitf4d006a8c841c2222e553389ce03eb17ff651dde (patch)
treee2adfd439006546525ef3c14f8b5dada615c3092 /CMakeLists.txt
parent5c791157e86fc00b3af92b4db0f48900838379ba (diff)
Remove RISCV from LLVM_ALL_TARGETS in CMakeLists.txt
It was mistakenly added to that list in D23560 (committed in rL285712). RISCV is an experimental backend and should never have been in that list, I mistakenly interpreted LLVM_ALL_TARGETS as a list of all targets rather than targets to build by default. Unfortunately, because of this the RISCV backend has been building by default when it shouldn't be. This commet adds a description comment, which should help to avoid such mistakes in the future. See my message to llvm-dev for more information and analysis <http://lists.llvm.org/pipermail/llvm-dev/2017-August/116347.html>. Differential Revision: https://reviews.llvm.org/D36538 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@310796 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fe5343bcadd..a056abeeb5f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -309,6 +309,7 @@ set(LLVM_CMAKE_PATH ${LLVM_MAIN_SRC_DIR}/cmake/modules)
set(LLVM_EXAMPLES_BINARY_DIR ${LLVM_BINARY_DIR}/examples)
set(LLVM_INCLUDE_DIR ${CMAKE_CURRENT_BINARY_DIR}/include)
+# List of all targets to be built by default:
set(LLVM_ALL_TARGETS
AArch64
AMDGPU
@@ -320,7 +321,6 @@ set(LLVM_ALL_TARGETS
MSP430
NVPTX
PowerPC
- RISCV
Sparc
SystemZ
X86