summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Braun <matze@braunis.de>2017-09-26 02:36:58 +0000
committerMatthias Braun <matze@braunis.de>2017-09-26 02:36:58 +0000
commitec9231b4baef60c23d26dfc144ba136f188f4325 (patch)
treef0b2b4bff87d8ead14956172d7f6f5972d5b0f32 /CMakeLists.txt
parent77cad59acfa86366b877b8c7d4203a21bd635b36 (diff)
CMake: Add option to set LLVM_ENABLE_DUMP
Differential Revision: https://reviews.llvm.org/D38267 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@314186 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4a188371901..b5454499df3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -396,6 +396,8 @@ endif()
option(LLVM_ENABLE_EXPENSIVE_CHECKS "Enable expensive checks" OFF)
+option(LLVM_ENABLE_DUMP "Enable dump functions in release builds" OFF)
+
set(LLVM_ABI_BREAKING_CHECKS "WITH_ASSERTS" CACHE STRING
"Enable abi-breaking checks. Can be WITH_ASSERTS, FORCE_ON or FORCE_OFF.")