summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2015-10-14 21:50:09 +0000
committerChris Bieneman <beanz@apple.com>2015-10-14 21:50:09 +0000
commitdf03dfef7d34a30659c10dd218a51e689fdf8c63 (patch)
treef7564048f02d88967732a8043a3e4198d91e0933 /CMakeLists.txt
parent8e770608715067248f27b0cbb8726d2cf4f69817 (diff)
[CMake] Make LLVM_VERSION_* variables user definable
CMake's set command overwrites existing values. Package maintainers may want or need to set the version variables manually, so we need to only set them if they are not already defined. Note I use the "if(NOT DEFINED ...)" syntax deliberately in the last case because empty string is a valid value for the suffx, but not the other variables. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@250333 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 12 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a1713fbb8f9..82e937e7ade 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,10 +26,18 @@ else()
set(cmake_3_2_USES_TERMINAL USES_TERMINAL)
endif()
-set(LLVM_VERSION_MAJOR 3)
-set(LLVM_VERSION_MINOR 8)
-set(LLVM_VERSION_PATCH 0)
-set(LLVM_VERSION_SUFFIX svn)
+if(NOT LLVM_VERSION_MAJOR)
+ set(LLVM_VERSION_MAJOR 3)
+endif()
+if(NOT LLVM_VERSION_MINOR)
+ set(LLVM_VERSION_MINOR 8)
+endif()
+if(NOT LLVM_VERSION_PATCH)
+ set(LLVM_VERSION_PATCH 0)
+endif()
+if(NOT DEFINED LLVM_VERSION_SUFFIX)
+ set(LLVM_VERSION_SUFFIX svn)
+endif()
if (POLICY CMP0048)
cmake_policy(SET CMP0048 NEW)