summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNAKAMURA Takumi <geek4civic@gmail.com>2017-07-19 10:47:38 +0000
committerNAKAMURA Takumi <geek4civic@gmail.com>2017-07-19 10:47:38 +0000
commitcb5b6da03e79e84174d524e64d21bac9bfd59a94 (patch)
tree8e745ef48e0e91189fd24a6fec939097c65d9b3b /CMakeLists.txt
parent55bda90186e24b9ad3bfcfc8e853311fab104cc2 (diff)
Revert r274270, "[CMake] Module builds depend on target intrinsics_gen to be built first."
I think modulemap is sufficient for intrinsics_gen in trunk. I won't find any issues around that. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@308434 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 61ecfdf970d..70bc63d9939 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -843,15 +843,6 @@ add_subdirectory(lib/TableGen)
add_subdirectory(utils/TableGen)
-# Force target to be built as soon as possible. Clang modules builds depend
-# header-wise on it as they ship all headers from the umbrella folders. Building
-# an entire module might include header, which depends on intrinsics_gen. This
-# should be right after LLVMSupport and LLVMTableGen otherwise we introduce a
-# circular dependence.
-if (LLVM_ENABLE_MODULES)
- list(APPEND LLVM_COMMON_DEPENDS intrinsics_gen)
-endif(LLVM_ENABLE_MODULES)
-
add_subdirectory(include/llvm)
add_subdirectory(lib)