summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2015-02-13 23:24:14 +0000
committerChris Bieneman <beanz@apple.com>2015-02-13 23:24:14 +0000
commitc4300b9c0147889e77d2a51ded9fa025545d27e2 (patch)
tree51d26af0c20dd89e853bea3f07728fb269f23082 /CMakeLists.txt
parent2e2ed16a3b86f8284c3d4389e4a0fe05b37f221b (diff)
Raising minimum required Visual Studio version to 2013.
This is based on the discussions on: [LLVMdev] [RFC] Raising LLVM minimum required MSVC version to 2013 for trunk git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@229185 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index afcc9f0ce2a..4f00395fd60 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,6 +24,10 @@ endif()
project(LLVM)
+if (MSVC AND MSVC_VERSION LESS 1800)
+ message(FATAL_ERROR "Minimum required MSVC version is 2013!")
+endif ()
+
# The following only works with the Ninja generator in CMake >= 3.0.
set(LLVM_PARALLEL_COMPILE_JOBS "" CACHE STRING
"Define the maximum number of concurrent compilation jobs.")