summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorReid Kleckner <rnk@google.com>2017-07-31 18:45:44 +0000
committerReid Kleckner <rnk@google.com>2017-07-31 18:45:44 +0000
commitc39935fb158d6ae19e24be858940c3c20bcd486e (patch)
treee37ccee07c9b6be964b7e293ec3ea9a6f30dec1e /CMakeLists.txt
parentf514aa4426f00af61f6b5647ab05969a4b28ad36 (diff)
[lit] Avoid copying llvm/utils/lit/tests/Inputs with lit site configs
Summary: This is an alternative solution to running the lit test suite on bots without polluting the source directory. Each input test suite gets an auto-generated site config in the build directory that points back to the test input source directory. This adds some cmake comlexity, but now we don't need to remove and re-copy the test input directory before every test. Reviewers: delcypher, modocache Subscribers: mgorny, llvm-commits Differential Revision: https://reviews.llvm.org/D36026 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@309602 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c2ce41761b4..647dbc007a2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -897,7 +897,7 @@ if( LLVM_INCLUDE_TESTS )
NO_INSTALL
ALWAYS_CLEAN)
endif()
- add_subdirectory(utils/lit)
+ add_subdirectory(utils/lit/tests)
add_subdirectory(test)
add_subdirectory(unittests)
if( LLVM_INCLUDE_UTILS )