summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZachary Turner <zturner@google.com>2017-09-15 02:56:40 +0000
committerZachary Turner <zturner@google.com>2017-09-15 02:56:40 +0000
commitb411a75baef5fa7c20186d9866964838397ad771 (patch)
tree6fa1adca6067d37a09307f5545d88f02ebb87f43 /CMakeLists.txt
parent4d63668031f8064e81747e3064fb2481a6e8f0cd (diff)
Revert "[lit] Force site configs to run before source-tree configs"
This patch is still breaking several multi-stage compiler-rt bots. I already know what the fix is, but I want to get the bots green for now and then try re-applying in the morning. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@313335 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 76d66b99fc8..d08fd67ddaf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -845,6 +845,7 @@ if( LLVM_INCLUDE_UTILS )
add_subdirectory(utils/PerfectShuffle)
add_subdirectory(utils/count)
add_subdirectory(utils/not)
+ add_subdirectory(utils/llvm-lit)
add_subdirectory(utils/yaml-bench)
else()
if ( LLVM_INCLUDE_TESTS )
@@ -931,11 +932,6 @@ endif()
add_subdirectory(cmake/modules)
-# Do this last so that all lit targets have already been created.
-if (LLVM_INCLUDE_UTILS)
- add_subdirectory(utils/llvm-lit)
-endif()
-
if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
install(DIRECTORY include/llvm include/llvm-c
DESTINATION include