summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorShoaib Meenai <smeenai@fb.com>2017-11-02 01:07:37 +0000
committerShoaib Meenai <smeenai@fb.com>2017-11-02 01:07:37 +0000
commitac57ff234758087cff1f77cde0331469636f1170 (patch)
tree1d4d5af6c63edb496aa0c550aef14860f9aed0d6 /CMakeLists.txt
parent2471073a0bf0f8dd545acd32b0d5174931dfee95 (diff)
[cmake] Switch FATAL_ERROR to SEND_ERROR
It's possible for multiple distribution components to have missing targets, and it's a lot more convenient to get all those errors in one shot rather than having to fix them individually. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@317148 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 90847d2c0d1..04565038311 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1001,13 +1001,13 @@ if(LLVM_DISTRIBUTION_COMPONENTS)
if(TARGET ${target})
add_dependencies(distribution ${target})
else()
- message(FATAL_ERROR "Specified distribution component '${target}' doesn't have a target")
+ message(SEND_ERROR "Specified distribution component '${target}' doesn't have a target")
endif()
if(TARGET install-${target})
add_dependencies(install-distribution install-${target})
else()
- message(FATAL_ERROR "Specified distribution component '${target}' doesn't have an install target")
+ message(SEND_ERROR "Specified distribution component '${target}' doesn't have an install target")
endif()
endforeach()
endif()