summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZachary Turner <zturner@google.com>2017-09-13 20:49:25 +0000
committerZachary Turner <zturner@google.com>2017-09-13 20:49:25 +0000
commita768fcb2648b65efb3f3afc0581ac04cc4ce8d2d (patch)
tree0b14cf13299f6854062b95a0af721d9b74f4010e /CMakeLists.txt
parent7f44c36d0722680aaaf12d6c9ebd714f4b6a4312 (diff)
Revert "Determine up front which projects are enabled."
This was intended to be a generic CMake solution to a problem shared across several projects. It turns out it doesn't interact very well certain CMake configurations, and furthermore the "problem" is actually not a problem, as the problematic code is never executed to begin with. So this really isn't solving anything. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@313191 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 0 insertions, 19 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cdeaf4ac706..d08fd67ddaf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -823,25 +823,6 @@ endif()
include(AddLLVM)
include(TableGen)
-
-# Find all subprojects which are either enabled in a side-by-side layout, or
-# cloned into a non-side-by-side layout. Do this before adding any
-# subdirectories so that any project can check for the existence of any other
-# project. Each call takes priority over the next call, so any project which
-# is enabled via LLVM_ENABLE_PROJECTS will not have its location or enabled
-# status overwritten via a subsequent call.
-
-# First look for all projects explicitly enabled at the root.
-find_llvm_enabled_projects("${LLVM_SOURCE_DIR}/.." "${LLVM_ENABLE_PROJECTS}")
-
-# Then pick up any projects explicitly cloned into llvm/projects or llvm/runtimes
-find_llvm_enabled_projects("${LLVM_SOURCE_DIR}/runtimes")
-find_llvm_enabled_projects("${LLVM_SOURCE_DIR}/projects")
-
-# Then pick up a few specific projects which can be explicit cloned into llvm/tools
-find_llvm_enabled_projects("${LLVM_SOURCE_DIR}/tools" "clang;lldb;lld")
-
-
if( MINGW )
# People report that -O3 is unreliable on MinGW. The traditional
# build also uses -O2 for that reason: