summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Morehouse <mascasa@google.com>2017-10-12 21:58:41 +0000
committerMatt Morehouse <mascasa@google.com>2017-10-12 21:58:41 +0000
commit8520e4812b6acaa0e24d5e633c0c882e19c6afa9 (patch)
treee2139114d77c70ea1702542ed0c4071af240ad63 /CMakeLists.txt
parentfcc479bedcebae06705fee7f557ab021db4f4d5a (diff)
[cmake] Allow building fuzzers with OSS-Fuzz flags.
Reviewers: kcc, bogner Reviewed By: bogner Subscribers: mgorny, llvm-commits Differential Revision: https://reviews.llvm.org/D38858 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@315629 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 47c15e73ff2..bf9e4f4985f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -435,6 +435,8 @@ endif( LLVM_USE_OPROFILE )
set(LLVM_USE_SANITIZER "" CACHE STRING
"Define the sanitizer used to build binaries and tests.")
+set(LLVM_LIB_FUZZING_ENGINE "" CACHE PATH
+ "Path to fuzzing library for linking with fuzz targets")
option(LLVM_USE_SPLIT_DWARF
"Use -gsplit-dwarf when compiling llvm." OFF)