summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRafael Espindola <rafael.espindola@gmail.com>2015-06-22 18:24:01 +0000
committerRafael Espindola <rafael.espindola@gmail.com>2015-06-22 18:24:01 +0000
commit84f9ca8e19feaf126e4673ca0ba520f21990478a (patch)
tree31db4b88c2f87061630194ad5d30b5180eb2660c /CMakeLists.txt
parentd5732752e84cc49d812dfc10a5df4133c5a6d14b (diff)
Do not pass -allow-shlib-undefined to the Solaris linker.
Patch by Xan López. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@240308 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index da731497997..3194197d7a1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -530,7 +530,7 @@ endif()
# check its symbols. This is wasteful (the check was done when foo.so
# was created) and can fail since it is not the dynamic linker and
# doesn't know how to handle search paths correctly.
-if (UNIX AND NOT APPLE)
+if (UNIX AND NOT APPLE AND NOT ${CMAKE_SYSTEM_NAME} MATCHES "SunOS")
set(CMAKE_EXE_LINKER_FLAGS
"${CMAKE_EXE_LINKER_FLAGS} -Wl,-allow-shlib-undefined")
endif()