summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZachary Turner <zturner@google.com>2017-11-17 00:41:18 +0000
committerZachary Turner <zturner@google.com>2017-11-17 00:41:18 +0000
commit56520dccc93c0d5b47be64b182931b18f68deb13 (patch)
treedf3c3025f22b334d5a26d1d1815a14cc2ebe537f /CMakeLists.txt
parent6d3e69e8141cbd4efe8f3c87b9355e015fc93150 (diff)
Re-revert "Refactor debuginfo-tests"
This is still broken because it causes certain tests to be run twice with slightly different configurations, which is wrong in some cases. You can observe this by running: ninja -nv check-all | grep debuginfo-tests And seeing that it passes clang/test and clang/test/debuginfo-tests to lit, which causes it to run debuginfo-tests twice. The fix is going to involve either: a) figuring out that we're running in this "deprecated" configuration, and then deleting the clang/test/debuginfo-tests path, which should cause it to behave identically to before, or: b) make lit smart enough that it doesn't descend into a sub-suite if that sub-suite already has a lit.cfg file. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@318486 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 7 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5f5b138b53b..8cd9d053c63 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -110,7 +110,7 @@ endif()
# LLVM_EXTERNAL_${project}_SOURCE_DIR using LLVM_ALL_PROJECTS
# This allows an easy way of setting up a build directory for llvm and another
# one for llvm+clang+... using the same sources.
-set(LLVM_ALL_PROJECTS "clang;libcxx;libcxxabi;lldb;compiler-rt;debuginfo-tests;lld;polly")
+set(LLVM_ALL_PROJECTS "clang;libcxx;libcxxabi;lldb;compiler-rt;lld;polly")
set(LLVM_ENABLE_PROJECTS "" CACHE STRING
"Semicolon-separated list of projects to build (${LLVM_ALL_PROJECTS}), or \"all\".")
if( LLVM_ENABLE_PROJECTS STREQUAL "all" )
@@ -885,18 +885,13 @@ if( LLVM_INCLUDE_EXAMPLES )
endif()
if( LLVM_INCLUDE_TESTS )
- if(TARGET clang)
+ if(EXISTS ${LLVM_MAIN_SRC_DIR}/projects/test-suite AND TARGET clang)
include(LLVMExternalProjectUtils)
- if (EXISTS ${LLVM_MAIN_SRC_DIR}/projects/test-suite)
- llvm_ExternalProject_Add(test-suite ${LLVM_MAIN_SRC_DIR}/projects/test-suite
- USE_TOOLCHAIN
- TOOLCHAIN_TOOLS clang lld clang-cl
- EXCLUDE_FROM_ALL
- NO_INSTALL
- ALWAYS_CLEAN)
- endif()
-
- add_llvm_external_project(debuginfo-tests projects/debuginfo-tests)
+ llvm_ExternalProject_Add(test-suite ${LLVM_MAIN_SRC_DIR}/projects/test-suite
+ USE_TOOLCHAIN
+ EXCLUDE_FROM_ALL
+ NO_INSTALL
+ ALWAYS_CLEAN)
endif()
add_subdirectory(utils/lit)
add_subdirectory(test)