summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAaron Ballman <aaron@aaronballman.com>2017-10-15 14:32:27 +0000
committerAaron Ballman <aaron@aaronballman.com>2017-10-15 14:32:27 +0000
commit1d03d382c1c3635a69713abdeac67bda48567762 (patch)
treeb51d3f57c3b321668e079a31763ffc482c3ff478 /CMakeLists.txt
parent99dc03a8d7128708d11433b72b549583c9c02e50 (diff)
Reverting r315590; it did not include changes for llvm-tblgen, which is causing link errors for several people.
Error LNK2019 unresolved external symbol "public: void __cdecl `anonymous namespace'::MatchableInfo::dump(void)const " (?dump@MatchableInfo@?A0xf4f1c304@@QEBAXXZ) referenced in function "public: void __cdecl `anonymous namespace'::AsmMatcherEmitter::run(class llvm::raw_ostream &)" (?run@AsmMatcherEmitter@?A0xf4f1c304@@QEAAXAEAVraw_ostream@llvm@@@Z) llvm-tblgen D:\llvm\2017\utils\TableGen\AsmMatcherEmitter.obj 1 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@315854 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bf9e4f4985f..a5419184325 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -388,15 +388,15 @@ option(LLVM_ENABLE_LLD "Use lld as C and C++ linker." OFF)
option(LLVM_ENABLE_PEDANTIC "Compile with pedantic enabled." ON)
option(LLVM_ENABLE_WERROR "Fail and stop if a warning is triggered." OFF)
+option(LLVM_ENABLE_DUMP "Enable dump functions in release builds" OFF)
+
if( NOT uppercase_CMAKE_BUILD_TYPE STREQUAL "DEBUG" )
option(LLVM_ENABLE_ASSERTIONS "Enable assertions" OFF)
- option(LLVM_FORCE_ENABLE_DUMP "Enable dump functions in release builds" OFF)
else()
option(LLVM_ENABLE_ASSERTIONS "Enable assertions" ON)
- option(LLVM_FORCE_ENABLE_DUMP "Enable dump functions in release builds" ON)
endif()
-if( LLVM_ENABLE_ASSERTIONS OR LLVM_FORCE_ENABLE_DUMP )
+if( LLVM_ENABLE_ASSERTIONS )
set(LLVM_ENABLE_DUMP ON)
endif()