summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrian Gesiak <modocache@gmail.com>2017-07-27 19:18:35 +0000
committerBrian Gesiak <modocache@gmail.com>2017-07-27 19:18:35 +0000
commit1571e4d949ee2e4a0c58533d9b1535f7c4387d2a (patch)
tree9a3eec0ff8b9a56ee05f36f4ab96cf7e096c0cbe /CMakeLists.txt
parent9fe81bfab04bffe6498ce871b2b05a4ebd12c023 (diff)
Un-revert "Teach the CMake build system to run lit's test suite. These can be run"
Summary: Depends on https://reviews.llvm.org/D35879. This reverts rL257268, which in turn was a revert of rL257221. https://reviews.llvm.org/D35879 marks the tests in the lit test suite that fail on Windows as XFAIL, which should allow these tests to pass on Windows-based buildbots. Reviewers: delcypher, beanz, mgorny, jroelofs, rnk Reviewed By: mgorny Subscribers: rnk, ddunbar, george.karpenkov, llvm-commits Differential Revision: https://reviews.llvm.org/D35880 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@309310 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c38c59843ea..c2ce41761b4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -897,6 +897,7 @@ if( LLVM_INCLUDE_TESTS )
NO_INSTALL
ALWAYS_CLEAN)
endif()
+ add_subdirectory(utils/lit)
add_subdirectory(test)
add_subdirectory(unittests)
if( LLVM_INCLUDE_UTILS )