summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2015-02-20 19:02:59 +0000
committerChris Bieneman <beanz@apple.com>2015-02-20 19:02:59 +0000
commit11947113de24f14f0bb7c7895b5087f001839e5d (patch)
treecfef2631a332a71097a35c0a7fe5dc4c5a417419 /CMakeLists.txt
parentef6e26ea1f5004ddc1daa7d2a207abe73f6b3377 (diff)
Setting up CMake to default to Debug when no build type is specified.
Summary: Turns out if you don't set CMAKE_BUILD_TYPE the default is an empty string. This results in some of the behaviors of debug builds, but not all of them. For example ENABLE_ASSERTIONS is false. Reviewers: rnk Reviewed By: rnk Subscribers: chapuni, llvm-commits Differential Revision: http://reviews.llvm.org/D7360 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@230041 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3da8ff01b24..27784c44892 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,11 @@
cmake_minimum_required(VERSION 2.8.8)
+if (NOT CMAKE_BUILD_TYPE AND NOT CMAKE_CONFIGURATION_TYPES)
+ message(STATUS "No build type selected, default to Debug")
+ set(CMAKE_BUILD_TYPE "Debug")
+endif()
+
# FIXME: It may be removed when we use 2.8.12.
if(CMAKE_VERSION VERSION_LESS 2.8.12)
# Invalidate a couple of keywords.