summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNAKAMURA Takumi <geek4civic@gmail.com>2015-02-15 17:53:10 +0000
committerNAKAMURA Takumi <geek4civic@gmail.com>2015-02-15 17:53:10 +0000
commit068db0bdb8039add959e5553686e1ac9867f6920 (patch)
treee166992c9e18829f3531db1f75ef4f0b39553f2d /CMakeLists.txt
parent962ebd4f23f61599b789bb213c3da82225459c16 (diff)
Reapply r229185(cbieneman) -- Raising minimum required Visual Studio version to 2013.
This is based on the discussions on: [LLVMdev] [RFC] Raising LLVM minimum required MSVC version to 2013 for trunk git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@229320 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index afcc9f0ce2a..4f00395fd60 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,6 +24,10 @@ endif()
project(LLVM)
+if (MSVC AND MSVC_VERSION LESS 1800)
+ message(FATAL_ERROR "Minimum required MSVC version is 2013!")
+endif ()
+
# The following only works with the Ninja generator in CMake >= 3.0.
set(LLVM_PARALLEL_COMPILE_JOBS "" CACHE STRING
"Define the maximum number of concurrent compilation jobs.")