summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorQuentin Colombet <qcolombet@apple.com>2017-08-03 21:52:25 +0000
committerQuentin Colombet <qcolombet@apple.com>2017-08-03 21:52:25 +0000
commitf6eeaf64bbdc80027309f5b8b827c9b36c3fe4b9 (patch)
tree909c3906e61ee6ef7cf3b91d3dddb9418c3124f2 /CMakeLists.txt
parent0d362a25a4451812b6ce70f6a97d504075f20fb9 (diff)
[GlobalISel] Make GlobalISel a non-optional library.
With this change, the GlobalISel library gets always built. In particular, this is not possible to opt GlobalISel out of the build using the LLVM_BUILD_GLOBAL_ISEL variable any more. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@309990 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c2ce41761b4..fe5343bcadd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -176,11 +176,6 @@ if(LLVM_DEPENDENCY_DEBUGGING)
endif()
endif()
-option(LLVM_BUILD_GLOBAL_ISEL "Experimental: Build GlobalISel" ON)
-if(LLVM_BUILD_GLOBAL_ISEL)
- add_definitions(-DLLVM_BUILD_GLOBAL_ISEL)
-endif()
-
option(LLVM_ENABLE_DAGISEL_COV "Debug: Prints tablegen patterns that were used for selecting" OFF)
# Add path for custom modules