summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin Bogner <mail@justinbogner.com>2018-06-11 23:05:28 +0000
committerJustin Bogner <mail@justinbogner.com>2018-06-11 23:05:28 +0000
commite5839ea3a47081b983dea1d186c1c13a38f2652c (patch)
tree53161ea42ebc94a2c6bd64cb596e00df5db13baf /CMakeLists.txt
parent23bfaae29f05dcbb1987c8ee624ad91393e16cae (diff)
[CMake] Fix dropped dependency in install-llvm-headers
This dependency was accidentally dropped in r319480, causing install-distribution and install-llvm-headers to install an incomplete set of headers (the generated Intrinsics and Attributes would be missing). git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@334452 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a22e6e9fcd2..a2085878166 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -985,6 +985,7 @@ if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
if (NOT CMAKE_CONFIGURATION_TYPES)
add_llvm_install_targets(install-llvm-headers
+ DEPENDS llvm-headers
COMPONENT llvm-headers)
endif()
endif()