summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Craig <ben.craig@codeaurora.org>2016-04-19 12:47:38 +0000
committerBen Craig <ben.craig@codeaurora.org>2016-04-19 12:47:38 +0000
commit81681aed99a11d4c3080a5aefd5e4be8e79f05ac (patch)
tree693929d4aa0ac839bc4c5c9abcc6bb8ea4a5f7dd /test/CMakeLists.txt
parent6b68c7c4491bb05e0e3b4167eb8bc650b5c34cad (diff)
Enable testing for static libc++abi
This change leverages framework changes made in libcxx. See those changes for more details. (http://reviews.llvm.org/D16544) Some Mac specific logic for testing against libc++abi had to be moved from libcxxabi's config.py, as it was overriding choices made in libcxx's config.py. That logic is now in libcxx's target_info.py. http://reviews.llvm.org/D16545 git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@266729 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index c61d4ad..aee9ffa 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -6,7 +6,12 @@ macro(pythonize_bool var)
endif()
endmacro()
+if (NOT DEFINED LIBCXX_ENABLE_SHARED)
+ set(LIBCXX_ENABLE_SHARED ON)
+endif()
+
pythonize_bool(LLVM_BUILD_32_BITS)
+pythonize_bool(LIBCXX_ENABLE_SHARED)
pythonize_bool(LIBCXXABI_ENABLE_SHARED)
pythonize_bool(LIBCXXABI_ENABLE_THREADS)
pythonize_bool(LIBCXXABI_USE_LLVM_UNWINDER)
@@ -22,7 +27,12 @@ configure_file(
${CMAKE_CURRENT_BINARY_DIR}/lit.site.cfg
@ONLY)
-set(LIBCXXABI_TEST_DEPS cxxabi_shared)
+if (LIBCXXABI_ENABLE_SHARED)
+ set(LIBCXXABI_TEST_DEPS cxxabi_shared)
+else()
+ set(LIBCXXABI_TEST_DEPS cxxabi_static)
+endif()
+
if (NOT LIBCXXABI_BUILT_STANDALONE)
list(APPEND LIBCXXABI_TEST_DEPS cxx)
endif()