summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorJonas Hahnfeld <Hahnfeld@itc.rwth-aachen.de>2016-03-17 10:00:24 +0000
committerJonas Hahnfeld <Hahnfeld@itc.rwth-aachen.de>2016-03-17 10:00:24 +0000
commit62c01cbb044c07350d493c5900b2325e5e46aaf4 (patch)
tree9dd949c3b237e89adb76f34b0b5ebd38a6773e1a /test/CMakeLists.txt
parenteca353d4849b2b1f7bca76edb40b3534433a5a26 (diff)
[libcxxabi] Disable cxa_thread_atexit_test if unavailable
The feature check is already in place when building the library but wasn't honored for the tests. Differential Revision: http://reviews.llvm.org/D18205 git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@263699 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index f77637e..c61d4ad 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -10,6 +10,7 @@ pythonize_bool(LLVM_BUILD_32_BITS)
pythonize_bool(LIBCXXABI_ENABLE_SHARED)
pythonize_bool(LIBCXXABI_ENABLE_THREADS)
pythonize_bool(LIBCXXABI_USE_LLVM_UNWINDER)
+pythonize_bool(LIBCXXABI_HAS_CXA_THREAD_ATEXIT_IMPL)
set(LIBCXXABI_TARGET_INFO "libcxx.test.target_info.LocalTI" CACHE STRING
"TargetInfo to use when setting up test environment.")
set(LIBCXXABI_EXECUTOR "None" CACHE STRING