summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Roelofs <jonathan@codesourcery.com>2015-02-26 15:55:01 +0000
committerJonathan Roelofs <jonathan@codesourcery.com>2015-02-26 15:55:01 +0000
commit60df04075a29eaa87521a6dad819a013f6345bad (patch)
tree2a0625b96cefd26abc00f0236cc4add4c3d0a973 /test/CMakeLists.txt
parent4cab028d3122674a78afd2b6846104a082b90e80 (diff)
Add remote testing support to the lit config
Now that the corresponding support in libcxx has landed (r230592), adding support here is pretty simple. git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@230643 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 8a713a6..103f559 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -10,6 +10,10 @@ pythonize_bool(LIBCXXABI_BUILD_32_BITS)
pythonize_bool(LIBCXXABI_ENABLE_SHARED)
pythonize_bool(LIBCXXABI_ENABLE_THREADS)
pythonize_bool(LIBCXXABI_USE_LLVM_UNWINDER)
+set(LIBCXXABI_TARGET_INFO "libcxx.test.target_info.LocalTI" CACHE STRING
+ "TargetInfo to use when setting up test environment.")
+set(LIBCXXABI_EXECUTOR "None" CACHE STRING
+ "Executor to use when running tests.")
set(AUTO_GEN_COMMENT "## Autogenerated by libcxxabi configuration.\n# Do not edit!")
configure_file(