summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorDan Albert <danalbert@google.com>2014-07-11 15:36:02 +0000
committerDan Albert <danalbert@google.com>2014-07-11 15:36:02 +0000
commit000b3c91c499c38ef98e68e0744789554c0b1dc8 (patch)
tree328f18f186982559e511b0562a9fd42093d8eef1 /test/CMakeLists.txt
parentf1982198cace0db98a24e75867fff51fcbcdd4d7 (diff)
Add support for building and testing the unwinder.
Note: The unwinder currently only works on Darwin and on ARM Linux. Non-ARM Linux support is not yet implemented, and will fail to build. git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@212824 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index a8fca75..1383cd7 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -10,6 +10,7 @@ set(LIBCXXABI_COMPILER ${CMAKE_CXX_COMPILER})
set(LIBCXXABI_SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/..)
set(LIBCXXABI_BINARY_DIR ${CMAKE_BINARY_DIR})
pythonize_bool(LIBCXXABI_ENABLE_SHARED)
+pythonize_bool(LIBCXXABI_USE_LLVM_UNWINDER)
set(AUTO_GEN_COMMENT "## Autogenerated by libcxxabi configuration.\n# Do not edit!")
configure_file(
@@ -22,6 +23,10 @@ if (NOT LIBCXXABI_BUILT_STANDALONE)
list(APPEND LIBCXXABI_TEST_DEPS cxx)
endif()
+if (LIBCXXABI_USE_LLVM_UNWINDER)
+ list(APPEND LIBCXXABI_TEST_DEPS unwind)
+endif()
+
add_lit_testsuite(check-libcxxabi "Running libcxxabi tests"
${CMAKE_CURRENT_BINARY_DIR}
DEPENDS ${LIBCXXABI_TEST_DEPS}