summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDan Albert <danalbert@google.com>2014-07-10 02:20:11 +0000
committerDan Albert <danalbert@google.com>2014-07-10 02:20:11 +0000
commitfd961bd8cdb57b57e8e34779a2b44db40cf4fb30 (patch)
tree30459e45f2b743ec328b1282d9556955e12898ad /src/CMakeLists.txt
parente11c1a7accabb346cbb6df59681675fe3f8d8ccb (diff)
Add lit configs for libcxxabi tests.
This makes running libcxxabi tests on Linux _much_ easier. Adds a check-libcxxabi target to cmake. Also defaults to building a dynamic libc++abi. This is so that the default options still test the libc++abi that is being built. There are two problems with testing a static libc++abi. In the case of a standalone build, the tests will link the system's libc++, which might not have been built against our libc++abi. In the case of an in tree build, libc++ will prefer a dynamic libc++abi from the system over a static libc++abi from the output directory. git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@212672 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d8f22b9..4bf860a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -48,13 +48,7 @@ else()
)
endif()
-if (LIBCXXABI_LIBCXX_INCLUDES)
- include_directories("${LIBCXXABI_LIBCXX_INCLUDES}")
-elseif (NOT LIBCXXABI_BUILT_STANDALONE)
- include_directories("${LLVM_MAIN_SRC_DIR}/projects/libcxx/include")
-else()
- include_directories("${LLVM_INCLUDE_DIR}/c++/v1")
-endif()
+include_directories("${LIBCXXABI_LIBCXX_INCLUDES}")
# Generate library list.
set(libraries ${LIBCXXABI_CXX_ABI_LIBRARIES})