summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@chromium.org>2016-08-09 21:28:52 +0000
committerPetr Hosek <phosek@chromium.org>2016-08-09 21:28:52 +0000
commite1b2d057559cb1b03825b96f7e6e7a5f3a2a6ac9 (patch)
tree432726fd95ecfa9168e9638d2bbb159881ab1cd5 /src/CMakeLists.txt
parent3f7e85b1c3498008a386f59dbfc4102fd4574c0e (diff)
Depend directly on unwind when not building standalone
When using libunwind and not building as standalone project, we can directly depend on the unwind library target. Differential Revision: https://reviews.llvm.org/D23289 git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@278169 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 163e8ce..3af703c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -56,9 +56,14 @@ append_if(libraries LIBCXXABI_HAS_C_LIB c)
if (LIBCXXABI_USE_LLVM_UNWINDER)
if (NOT LIBCXXABI_BUILT_STANDALONE)
- link_directories(${LLVM_LIBRARY_DIR})
+ if (LIBUNWIND_ENABLE_SHARED)
+ list(APPEND libraries unwind_shared)
+ else()
+ list(APPEND libraries unwind_static)
+ endif()
+ else()
+ list(APPEND libraries unwind)
endif()
- list(APPEND libraries unwind)
else()
append_if(libraries LIBCXXABI_HAS_GCC_S_LIB gcc_s)
endif()