summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorIgor Kudrin <ikudrin.dev@gmail.com>2016-10-07 08:48:28 +0000
committerIgor Kudrin <ikudrin.dev@gmail.com>2016-10-07 08:48:28 +0000
commitace657208972b9d29bff7e062a19f59199133a4d (patch)
tree67abd4c8253423b554220f454c8b7ac327dbbcdd /src/CMakeLists.txt
parent8d4d9af454a985d8c10ffdb0c56e87efec25ddff (diff)
Recommit r282692: [libc++abi] Use fallback_malloc to allocate __cxa_eh_globals in case of dynamic memory exhaustion.
Throwing an exception for the first time may lead to call calloc to allocate memory for __cxa_eh_globals. If the memory pool is exhausted at that moment, it results in abnormal termination of the program. This patch addresses the issue by using fallback_malloc in that case. In this revision, some restrictions were added into the test to not run it in unsuitable environments. Differential Revision: https://reviews.llvm.org/D17815 git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@283531 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d951292..7cbfdf5 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -12,6 +12,7 @@ set(LIBCXXABI_SOURCES
cxa_vector.cpp
cxa_virtual.cpp
exception.cpp
+ fallback_malloc.cpp
private_typeinfo.cpp
stdexcept.cpp
typeinfo.cpp