summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDan Albert <danalbert@google.com>2014-07-11 15:36:02 +0000
committerDan Albert <danalbert@google.com>2014-07-11 15:36:02 +0000
commit000b3c91c499c38ef98e68e0744789554c0b1dc8 (patch)
tree328f18f186982559e511b0562a9fd42093d8eef1 /src/CMakeLists.txt
parentf1982198cace0db98a24e75867fff51fcbcdd4d7 (diff)
Add support for building and testing the unwinder.
Note: The unwinder currently only works on Darwin and on ARM Linux. Non-ARM Linux support is not yet implemented, and will fail to build. git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@212824 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4bf860a..ae0befb 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -19,13 +19,7 @@ set(LIBCXXABI_SOURCES
typeinfo.cpp
)
-set(LIBCXXABI_HEADERS
- ../include/cxxabi.h
- ../include/libunwind.h
- ../include/unwind.h
-)
-
-append_if(LIBCXXABI_HEADERS APPLE ../include/mach-o/compact_unwind_encoding.h)
+set(LIBCXXABI_HEADERS ../include/cxxabi.h)
# Add all the headers to the project for IDEs.
if (MSVC_IDE OR XCODE)