summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAnton Korobeynikov <asl@math.spbu.ru>2015-05-09 21:03:01 +0000
committerAnton Korobeynikov <asl@math.spbu.ru>2015-05-09 21:03:01 +0000
commitf66266681457ddc688c070adb128eee1146e86bb (patch)
treeacad3374423bf1bb389fc6096164eb83e4462c08 /CMakeLists.txt
parentf273775fb2027a4231b0fe3b259cbf389432029b (diff)
LIBCXXABI_LIBUNWIND_INCLUDES is already set before calling find_path, and find_path will not update it.
So cmake will throw error "include_directories given empty-string as include directory". Use other variable name for the include path and do not find the default libunwind.h in the system path. http://reviews.llvm.org/D9641 Patch by Jingyi Wei! git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@236936 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 71ffdbc..cd8b753 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -307,12 +307,13 @@ set(LIBCXXABI_LIBUNWIND_PATH "${LIBCXXABI_LIBUNWIND_PATH}" CACHE PATH
include_directories(include)
if (LIBCXXABI_USE_LLVM_UNWINDER OR LLVM_NATIVE_ARCH MATCHES ARM)
find_path(
- LIBCXXABI_LIBUNWIND_INCLUDES
+ LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL
libunwind.h
PATHS ${LIBCXXABI_LIBUNWIND_INCLUDES}
${LIBCXXABI_LIBUNWIND_PATH}/include
${CMAKE_BINARY_DIR}/${LIBCXXABI_LIBUNWIND_INCLUDES}
${LLVM_MAIN_SRC_DIR}/projects/libunwind/include
+ NO_DEFAULT_PATH
)
find_path(
@@ -329,7 +330,7 @@ if (LIBCXXABI_USE_LLVM_UNWINDER OR LLVM_NATIVE_ARCH MATCHES ARM)
set(LIBCXXABI_LIBUNWIND_SOURCES "")
endif()
- include_directories("${LIBCXXABI_LIBUNWIND_INCLUDES}")
+ include_directories("${LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL}")
include_directories("${LIBCXXABI_LIBUNWIND_SOURCES}")
endif ()