summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@chromium.org>2016-11-09 03:22:19 +0000
committerPetr Hosek <phosek@chromium.org>2016-11-09 03:22:19 +0000
commiteecb79506d88b268fb0d00cce178213b4aa17933 (patch)
tree20a5e43416afe3f196fb20afd45954511df5cde5 /CMakeLists.txt
parentcf209cc03680bc8119e763605cd22726e9956849 (diff)
[CMake] Check runtimes subdir when looking for libcxx and libuwind
The runtimes subdir is the new location for runtimes, we should include it when looking for libcxx and libunwind headers. Differential Revision: https://reviews.llvm.org/D26362 git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@286332 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dcfdf0f..5768bfe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -140,7 +140,10 @@ endif()
if (LLVM_EXTERNAL_LIBCXX_SOURCE_DIR)
set(LIBCXXABI_LIBCXX_SRC_DIR ${LLVM_EXTERNAL_LIBCXX_SOURCE_DIR})
else()
- set(LIBCXXABI_LIBCXX_SRC_DIR ${LLVM_MAIN_SRC_DIR}/projects/libcxx)
+ set(LIBCXXABI_LIBCXX_SRC_DIR
+ "${LLVM_MAIN_SRC_DIR}/projects/libcxx"
+ "${LLVM_MAIN_SRC_DIR}/runtimes/libcxx"
+ )
endif()
find_path(
@@ -380,6 +383,7 @@ if (LIBCXXABI_USE_LLVM_UNWINDER OR LLVM_NATIVE_ARCH MATCHES ARM)
${LIBCXXABI_LIBUNWIND_PATH}/include
${CMAKE_BINARY_DIR}/${LIBCXXABI_LIBUNWIND_INCLUDES}
${LLVM_MAIN_SRC_DIR}/projects/libunwind/include
+ ${LLVM_MAIN_SRC_DIR}/runtimes/libunwind/include
NO_DEFAULT_PATH
)
@@ -389,6 +393,7 @@ if (LIBCXXABI_USE_LLVM_UNWINDER OR LLVM_NATIVE_ARCH MATCHES ARM)
PATHS ${LIBCXXABI_LIBUNWIND_PATH}/src/
${LIBCXXABI_LIBUNWIND_INCLUDES}/../src/
${LLVM_MAIN_SRC_DIR}/projects/libunwind/src/
+ ${LLVM_MAIN_SRC_DIR}/runtimes/libunwind/src/
NO_DEFAULT_PATH
)