summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Fiselier <eric@efcs.ca>2017-03-02 21:55:17 +0000
committerEric Fiselier <eric@efcs.ca>2017-03-02 21:55:17 +0000
commited5abb1a7c76255a3fca13c1b26fc3c4f1aac5e9 (patch)
tree36244861bd7e116ec06a034b0155ef03469b3405 /CMakeLists.txt
parent4841062bd3d3a4b2c2d49e73972feed0342b53e0 (diff)
Work around GCC linking errors within libc++abi due to missing new/delete definitions
git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@296823 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6f54b91..249494d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -141,9 +141,13 @@ option(LIBCXXABI_HAS_EXTERNAL_THREAD_API
option(LIBCXXABI_BUILD_EXTERNAL_THREAD_LIBRARY
"Build libc++abi with an externalized threading library.
This option may only be set to ON when LIBCXXABI_ENABLE_THREADS=ON" OFF)
+
+# FIXME: This option should default to off. Unfortunatly GCC 4.9 fails to link
+# programs to due undefined references to new/delete in libc++abi. Once this
+# has been fixed or worked around the default value should be changed.
option(LIBCXXABI_ENABLE_NEW_DELETE_DEFINITIONS
"Build libc++abi with definitions for operator new/delete. Normally libc++
- provides these definitions" OFF)
+ provides these definitions" ON)
option(LIBCXXABI_BUILD_32_BITS "Build 32 bit libc++abi." ${LLVM_BUILD_32_BITS})
option(LIBCXXABI_INCLUDE_TESTS "Generate build targets for the libc++abi unit tests." ${LLVM_INCLUDE_TESTS})
set(LIBCXXABI_TARGET_TRIPLE "" CACHE STRING "Target triple for cross compiling.")