summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@compnerd.org>2015-04-27 18:19:33 +0000
committerSaleem Abdulrasool <compnerd@compnerd.org>2015-04-27 18:19:33 +0000
commite399cfbe0777ad9bfaece0fbb358ce24f185e644 (patch)
tree7a54f8b832058c294eacea7e0d65f4cf0ad7003a /CMakeLists.txt
parentb2cceca1296516dad3fbd93c988bbff1fd71cd7a (diff)
libc++abi: enable LLVM unwinder by default for ARM
libc++abi uses EHABI extensions, which are only part of the LLVM unwinder. When targeting ARM by default, enable the use of the LLVM unwinder. Hopefully this will fix the ARM native bot git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@235904 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 121b468..cab24b7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -114,7 +114,12 @@ endif()
option(LIBCXXABI_ENABLE_ASSERTIONS "Enable assertions independent of build mode." ON)
option(LIBCXXABI_ENABLE_PEDANTIC "Compile with pedantic enabled." ON)
option(LIBCXXABI_ENABLE_WERROR "Fail and stop if a warning is triggered." OFF)
-option(LIBCXXABI_USE_LLVM_UNWINDER "Build and use the LLVM unwinder." OFF)
+set(LIBCXXABI_USE_LLVM_UNWINDER_DEFAULT OFF)
+if (${LLVM_NATIVE_ARCH} MATCHES arm)
+ set(LIBCXXABI_USE_LLVM_UNWINDER_DEFAULT ON)
+endif ()
+option(LIBCXXABI_USE_LLVM_UNWINDER "Build and use the LLVM unwinder."
+ ${LIBCXXABI_USE_LLVM_UNWINDER_DEFAULT})
option(LIBCXXABI_ENABLE_THREADS "Build with threads enabled" ON)
set(LIBCXXABI_GCC_TOOLCHAIN "" CACHE STRING "GCC toolchain for cross compiling.")
set(LIBCXXABI_SYSROOT "" CACHE STRING "Sysroot for cross compiling.")