summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEugene Zelenko <eugene.zelenko@gmail.com>2016-08-08 17:59:02 +0000
committerEugene Zelenko <eugene.zelenko@gmail.com>2016-08-08 17:59:02 +0000
commit9987410774ac4d0b7e35fff4caba6db16b285919 (patch)
tree609e5f15dedf4fd1cdf1a80ee98e774f36b61e10 /CMakeLists.txt
parenteace9ece8ae60cdc2508fd2041324870bb129902 (diff)
CMakeLists.txt cleanups: synchronize version with rest of LLVM, consistent spacing.
Differential revision: https://reviews.llvm.org/D23092 git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@278030 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 54650eb..e6856c7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -64,7 +64,7 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
endif()
set(PACKAGE_NAME libcxxabi)
- set(PACKAGE_VERSION 3.7.0svn)
+ set(PACKAGE_VERSION 4.0.0svn)
set(PACKAGE_STRING "${PACKAGE_NAME} ${PACKAGE_VERSION}")
set(PACKAGE_BUGREPORT "llvm-bugs@lists.llvm.org")
@@ -189,8 +189,7 @@ set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${LIBCXXABI_LIBRARY_DIR})
if (NOT LIBCXXABI_LIBCXX_LIBRARY_PATH)
set(LIBCXXABI_LIBCXX_LIBRARY_PATH "${LIBCXXABI_LIBRARY_DIR}" CACHE PATH
"The path to libc++ library.")
-endif ()
-
+endif()
# Check that we can build with 32 bits if requested.
if (CMAKE_SIZEOF_VOID_P EQUAL 8 AND NOT WIN32)
@@ -246,7 +245,7 @@ endif()
if (LIBCXXABI_USE_COMPILER_RT)
list(APPEND LIBCXXABI_LINK_FLAGS "-rtlib=compiler-rt")
-endif ()
+endif()
append_if(LIBCXXABI_COMPILE_FLAGS LIBCXXABI_HAS_WERROR_FLAG -Werror=return-type)
@@ -383,7 +382,7 @@ if (LIBCXXABI_USE_LLVM_UNWINDER OR LLVM_NATIVE_ARCH MATCHES ARM)
include_directories("${LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL}")
include_directories("${LIBCXXABI_LIBUNWIND_SOURCES}")
-endif ()
+endif()
# Add source code. This also contains all of the logic for deciding linker flags
# soname, etc...