summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMartell Malone <martellmalone@gmail.com>2017-05-28 22:46:50 +0000
committerMartell Malone <martellmalone@gmail.com>2017-05-28 22:46:50 +0000
commit9111b9c5390c6011dc5c256e0f6ae92d6e568228 (patch)
tree2cc493f93ae02bd043a017d6425c3146132f619a /CMakeLists.txt
parent75fa911871321619ed953e11cb8c60002a4bb2dc (diff)
[libcxxabi] Disable DLL annotations on static
rL288692 renames _LIBCXXABI_DISABLE_DLL_IMPORT_EXPORT to _LIBCXXABI_DISABLE_VISIBILITY_ANNOTATIONS git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@304110 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2a0b4da..90ef7c6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -322,7 +322,7 @@ add_definitions(-D_LIBCXXABI_BUILDING_LIBRARY)
# Disable DLL annotations on Windows for static builds.
if (WIN32 AND LIBCXXABI_ENABLE_STATIC AND NOT LIBCXXABI_ENABLE_SHARED)
- add_definitions(-D_LIBCXXABI_DISABLE_DLL_IMPORT_EXPORT)
+ add_definitions(-D_LIBCXXABI_DISABLE_VISIBILITY_ANNOTATIONS)
endif()
append_if(LIBCXXABI_COMPILE_FLAGS LIBCXXABI_HAS_WERROR_FLAG -Werror=return-type)