summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Fiselier <eric@efcs.ca>2017-05-31 22:11:42 +0000
committerEric Fiselier <eric@efcs.ca>2017-05-31 22:11:42 +0000
commit7512331622d78a262298560330e4a39d69892203 (patch)
treee2ee95ff58ceda7b6d37dfe28756ec74264e204a /CMakeLists.txt
parentdb46267ecb10530054009e6db25d2d39fb1cc2ab (diff)
Remove requirement for libunwind sources. Patch by Shiz.
As per r241993, libunwind_ext.h is not used anymore, and thus only the public libunwind includes are needed. This eases distro packaging efforts and removes an unneeded requirement for out-of-tree building. Reviewed as D33178 git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@304359 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 0 insertions, 19 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 90ef7c6..07ad0c6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -504,21 +504,6 @@ if (LIBCXXABI_USE_LLVM_UNWINDER OR LLVM_NATIVE_ARCH MATCHES ARM)
NO_DEFAULT_PATH
)
- find_path(
- LIBCXXABI_LIBUNWIND_SOURCES
- libunwind_ext.h
- PATHS ${LIBCXXABI_LIBUNWIND_PATH}/src/
- ${LIBCXXABI_LIBUNWIND_INCLUDES}/../src/
- ${LLVM_MAIN_SRC_DIR}/projects/libunwind/src/
- ${LLVM_MAIN_SRC_DIR}/runtimes/libunwind/src/
- NO_DEFAULT_PATH
- )
-
- if (LIBCXXABI_LIBUNWIND_SOURCES STREQUAL "LIBCXXABI_LIBUNWIND_SOURCES-NOTFOUND")
- message(WARNING "LIBCXXABI_LIBUNWIND_SOURCES was not specified and couldn't be infered.")
- set(LIBCXXABI_LIBUNWIND_SOURCES "")
- endif()
-
if (LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL STREQUAL "LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL-NOTFOUND")
set(LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL "")
endif()
@@ -526,10 +511,6 @@ if (LIBCXXABI_USE_LLVM_UNWINDER OR LLVM_NATIVE_ARCH MATCHES ARM)
if (NOT LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL STREQUAL "")
include_directories("${LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL}")
endif()
-
- if (NOT LIBCXXABI_LIBUNWIND_SOURCES STREQUAL "")
- include_directories("${LIBCXXABI_LIBUNWIND_SOURCES}")
- endif()
endif()
# Add source code. This also contains all of the logic for deciding linker flags