summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKostya Serebryany <kcc@google.com>2016-12-28 03:28:29 +0000
committerKostya Serebryany <kcc@google.com>2016-12-28 03:28:29 +0000
commit6e0f5efa6607e6a9cd3c8999aa4141046d433fbb (patch)
tree4afc1942cb90d69199a5b2051780e54915c80fca /CMakeLists.txt
parenta3f4893c54ebd8662b1a8f079fa31beabeb54b90 (diff)
add cxa_demangle_fuzzer
Summary: All easy-to-find bugs in cxa_demangle where fixed now (https://bugs.chromium.org/p/chromium/issues/detail?id=606626) except for one (https://llvm.org/bugs/show_bug.cgi?id=31031). Now I'd like to properly integrate this fuzzer with the source tree and then run the fuzzer continuously on https://github.com/google/oss-fuzz Reviewers: compnerd, mclow.lists, mehdi_amini Subscribers: cfe-commits, mgorny Differential Revision: https://reviews.llvm.org/D28133 git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@290650 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5eb0109..dbb3602 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -432,4 +432,5 @@ if (LIBCXXABI_STANDALONE_BUILD AND NOT LIBCXXABI_ENABLE_SHARED)
"available!")
else()
add_subdirectory(test)
+ add_subdirectory(fuzz)
endif()