summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Fiselier <eric@efcs.ca>2016-11-13 22:27:00 +0000
committerEric Fiselier <eric@efcs.ca>2016-11-13 22:27:00 +0000
commit110520227e841104d38f826174302ff7068b2611 (patch)
treefd6ddcddffca839dbb64e0612717edb0fe39d9c7 /CMakeLists.txt
parentcc4f512be04098946b4f875d18bd4d69cbcd7463 (diff)
Fix GCC libc++abi build
git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@286783 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b23936e..5eb0109 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -249,6 +249,10 @@ add_target_flags_if(LIBCXXABI_GCC_TOOLCHAIN
add_target_flags_if(LIBCXXABI_SYSROOT
"--sysroot=${LIBCXXABI_SYSROOT}")
+if (LIBCXXABI_TARGET_TRIPLE)
+ set(TARGET_TRIPLE "${LIBCXXABI_TARGET_TRIPLE}")
+endif()
+
# Configure compiler. Must happen after setting the target flags.
include(config-ix)