summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAsiri Rathnayake <asiri.rathnayake@arm.com>2017-04-04 14:03:54 +0000
committerAsiri Rathnayake <asiri.rathnayake@arm.com>2017-04-04 14:03:54 +0000
commit0a3a1a8a5ca5ef69e0f6b7d5b9d13e63e6fd2c19 (patch)
tree4eba99dfb042196bbb549089395675de62996905 /CMakeLists.txt
parent66db5e3ea75d0f8a9c4f6e7f4672bc219c326ab8 (diff)
Fix exception address alignment test for EHABI
This test fails on ARM bare-metal targets because it assumes the Itanium ABI, whereas EHABI requires the exception address to be 8-byte aligned. I was a bit puzzled at first because this should've failed on the public arm-linux builder too. I think the reason it passes there is because we don't include libunwind headers in the include path when running the libcxxabi tests, so the system unwind.h gets picked up. Reviewers: rengolin, EricWF Differential revision: https://reviews.llvm.org/D31178 git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@299435 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index be76724..162db8e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -502,9 +502,14 @@ if (LIBCXXABI_USE_LLVM_UNWINDER OR LLVM_NATIVE_ARCH MATCHES ARM)
set(LIBCXXABI_LIBUNWIND_SOURCES "")
endif()
- if (NOT LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL STREQUAL "LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL-NOTFOUND")
+ if (LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL STREQUAL "LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL-NOTFOUND")
+ set(LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL "")
+ endif()
+
+ if (NOT LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL STREQUAL "")
include_directories("${LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL}")
endif()
+
if (NOT LIBCXXABI_LIBUNWIND_SOURCES STREQUAL "")
include_directories("${LIBCXXABI_LIBUNWIND_SOURCES}")
endif()