summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBryant Wong <llvm-commits@xorshift.org>2017-01-08 00:33:30 +0000
committerBryant Wong <llvm-commits@xorshift.org>2017-01-08 00:33:30 +0000
commit06da4e1fe2a69d191d9de30dba3afda1fbb83fb5 (patch)
tree6563b53dbbc79a71f566288ed087294908eeb7ea /CMakeLists.txt
parentebc9acae35430d23364e938f2e64e400d9df1e78 (diff)
[libcxxabi] Enable tests by default in standalone.
Tests targets will now be enabled by default when building libcxxabi out of tree (unless turned off with LIBCXXABI_INCLUDE_TESTS=OFF). Differential Revision: https://reviews.llvm.org/D28450 git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@291378 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c7d84ce..66a0a3f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -70,6 +70,10 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
set(PACKAGE_STRING "${PACKAGE_NAME} ${PACKAGE_VERSION}")
set(PACKAGE_BUGREPORT "llvm-bugs@lists.llvm.org")
+ if (NOT DEFINED LLVM_INCLUDE_TESTS)
+ set(LLVM_INCLUDE_TESTS ON)
+ endif()
+
if(EXISTS ${LLVM_MAIN_SRC_DIR}/utils/lit/lit.py)
set(LLVM_LIT ${LLVM_MAIN_SRC_DIR}/utils/lit/lit.py)
else()