summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorShoaib Meenai <smeenai@fb.com>2017-05-10 21:52:39 +0000
committerShoaib Meenai <smeenai@fb.com>2017-05-10 21:52:39 +0000
commit03d803fd6acf64a450adc6680e8f91fc3685bcbc (patch)
tree238e015a02ea06ced0289dd3b33c772929193541 /CMakeLists.txt
parentf8b91eec1e5d61d637ffb53561acaa561ab4d897 (diff)
[libc++abi] Disable libc++ extern templates project-wide
libc++abi can't depend on libc++, so disable extern templates in libc++ headers project-wide. This was previously done in cxa_demangle.cpp, but I consider it more appropriate to do at the cmake level (since none of libc++abi's source files can use libc++ extern templates). I also think the _LIBCPP_NO_EXCEPTIONS in cxa_demangle.cpp is suspicious, but I'm doing one thing at a time. Differential Revision: https://reviews.llvm.org/D32329 git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@302739 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 349e613..9b3e9c4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -457,6 +457,9 @@ if (LIBCXXABI_BUILD_EXTERNAL_THREAD_LIBRARY)
add_definitions(-D_LIBCPP_HAS_THREAD_LIBRARY_EXTERNAL)
endif()
+# Prevent libc++abi from having library dependencies on libc++
+add_definitions(-D_LIBCPP_DISABLE_EXTERN_TEMPLATE)
+
if (MSVC)
add_definitions(-D_CRT_SECURE_NO_WARNINGS)
endif()