summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDan Albert <danalbert@google.com>2014-07-11 15:36:02 +0000
committerDan Albert <danalbert@google.com>2014-07-11 15:36:02 +0000
commit000b3c91c499c38ef98e68e0744789554c0b1dc8 (patch)
tree328f18f186982559e511b0562a9fd42093d8eef1 /CMakeLists.txt
parentf1982198cace0db98a24e75867fff51fcbcdd4d7 (diff)
Add support for building and testing the unwinder.
Note: The unwinder currently only works on Darwin and on ARM Linux. Non-ARM Linux support is not yet implemented, and will fail to build. git-svn-id: https://llvm.org/svn/llvm-project/libcxxabi/trunk@212824 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e6bef80..bbb48b3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -104,6 +104,7 @@ endif()
option(LIBCXXABI_ENABLE_ASSERTIONS "Enable assertions independent of build mode." ON)
option(LIBCXXABI_ENABLE_PEDANTIC "Compile with pedantic enabled." ON)
option(LIBCXXABI_ENABLE_WERROR "Fail and stop if a warning is triggered." OFF)
+option(LIBCXXABI_USE_LLVM_UNWINDER "Build and use the LLVM unwinder." OFF)
# Default to building a shared library so that the default options still test
# the libc++abi that is being built. There are two problems with testing a
@@ -243,6 +244,10 @@ include_directories(include)
# soname, etc...
add_subdirectory(src)
+if (LIBCXXABI_USE_LLVM_UNWINDER)
+ add_subdirectory(src/Unwind)
+endif()
+
if(NOT LIBCXXABI_ENABLE_SHARED)
# TODO: Fix the libc++ cmake files so that libc++abi can be statically linked.
# As it is now, libc++ will prefer linking against a dynamic libc++abi in the