summaryrefslogtreecommitdiff
path: root/include/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Fiselier <eric@efcs.ca>2016-11-14 02:43:12 +0000
committerEric Fiselier <eric@efcs.ca>2016-11-14 02:43:12 +0000
commit5e000c6a82ce53740b3845fbacf107f9b4af1f39 (patch)
treedb3f1cb6ca95644f053764ca82981e76369ee76b /include/CMakeLists.txt
parent763984ea8d4edc30d7a716256e2aeb2e680e396a (diff)
Add check-cxx-abilist target when supported.
This patch adds a `check-cxx-abilist` target which verifies the libc++.so ABI when the current build configuration matches the configuration used to generate the ABI lists. In order to make this change `HandleOutOfTreeLLVM.cmake` needed to be modified to include `LLVMConfig.cmake` so that `TARGET_TRIPLE` is defined. Hopefully the changes needed to accommodate this won't break existing build configurations. git-svn-id: https://llvm.org/svn/llvm-project/libcxx/trunk@286789 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'include/CMakeLists.txt')
-rw-r--r--include/CMakeLists.txt16
1 files changed, 10 insertions, 6 deletions
diff --git a/include/CMakeLists.txt b/include/CMakeLists.txt
index deed1a110..5969c6fa8 100644
--- a/include/CMakeLists.txt
+++ b/include/CMakeLists.txt
@@ -10,14 +10,18 @@ set(LIBCXX_HEADER_PATTERN
${LIBCXX_SUPPORT_HEADER_PATTERN}
)
-if(NOT LIBCXX_USING_INSTALLED_LLVM)
- file(COPY .
- DESTINATION "${LLVM_BINARY_DIR}/include/c++/v1"
- FILES_MATCHING
- ${LIBCXX_HEADER_PATTERN}
- )
+if (LIBCXX_STANDALONE_BUILD)
+ set(LIBCXX_BUILD_ROOT "${LIBCXX_BINARY_DIR}")
+else()
+ set(LIBCXX_BUILD_ROOT "${LLVM_BINARY_DIR}")
endif()
+file(COPY .
+ DESTINATION "${LIBCXX_BUILD_ROOT}/include/c++/v1"
+ FILES_MATCHING
+ ${LIBCXX_HEADER_PATTERN}
+)
+
if (LIBCXX_INSTALL_HEADERS)
install(DIRECTORY .
DESTINATION include/c++/v1