summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorShoaib Meenai <smeenai@fb.com>2017-04-13 16:27:38 +0000
committerShoaib Meenai <smeenai@fb.com>2017-04-13 16:27:38 +0000
commitb975b451afb5b4fde42e7422ea4c54cdc3cffa8a (patch)
tree5db8fd0c1b83454f0722d61a8aa45b8bedd70a22 /CMakeLists.txt
parent9ac5bc55962461645e741c64fba3b0c85cd3b8b3 (diff)
[libc++] Explicitly set output directory for DLL
DLLs on Windows are treated as runtime targets. Explicitly set the output directory for them, to be consistent with other platforms. git-svn-id: https://llvm.org/svn/llvm-project/libcxx/trunk@300206 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 53904a16a..9c16dbed5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -347,6 +347,7 @@ file(MAKE_DIRECTORY "${LIBCXX_BINARY_INCLUDE_DIR}")
set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${LIBCXX_LIBRARY_DIR})
set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${LIBCXX_LIBRARY_DIR})
+set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${LIBCXX_LIBRARY_DIR})
# Declare libc++ configuration variables.
# They are intended for use as follows: