summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZachary Turner <zturner@google.com>2017-09-19 03:11:35 +0000
committerZachary Turner <zturner@google.com>2017-09-19 03:11:35 +0000
commit81306615ac5058533f1dfa76acc5d88651688277 (patch)
treec902e59f9c5ebad024375a677fe7c5d0f22e27ec /CMakeLists.txt
parent2205438c1fcbd01d0471879f165c2b26f275dbbd (diff)
Revert "Fix llvm-lit script generation in libcxx."
This reverts commit 4ad71811d45268d81b60f27e3b8b2bcbc23bd7b9. There is a bot that is checking out libcxx and lit with nothing else and then running lit.py against the test tree. Since there's no LLVM source tree, there's no LLVM CMake. CMake actually reports this as a warning saying unsupported libcxx configuration, but I guess someone is depending on it anyway. git-svn-id: https://llvm.org/svn/llvm-project/libcxx/trunk@313607 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f2b7f83dd..e402dae66 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -653,7 +653,6 @@ endif()
#
# However, since some submission systems strip test/ subdirectories, check for
# it before adding it.
-
if(IS_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/test")
add_subdirectory(test)
endif()
@@ -661,15 +660,6 @@ if (LIBCXX_INCLUDE_TESTS)
add_subdirectory(lib/abi)
endif()
-if (LIBCXX_STANDALONE_BUILD AND EXISTS "${LLVM_MAIN_SRC_DIR}/utils/llvm-lit")
- # Make sure the llvm-lit script is generated into the bin directory, and do
- # it after adding all tests, since the generated script will only work
- # correctly discovered tests against test locations from the source tree that
- # have already been discovered.
- add_subdirectory(${LLVM_MAIN_SRC_DIR}/utils/llvm-lit
- ${CMAKE_CURRENT_BINARY_DIR}/llvm-lit)
-endif()
-
if (LIBCXX_INCLUDE_DOCS)
add_subdirectory(docs)
endif()